Errata list for using Virtualbox

Error 1: During setup ./bootstrap, if you meet something as follows. 
automake: warning: possible forward-incompatibility.
automake: At least a source file is in a subdirectory, but the 'subdir-objects'
automake: automake option hasn't been enabled.  For now, the corresponding output
automake: object file(s) will be placed in the top-level directory.  However,
automake: this behaviour will change in future Automake versions: they will
automake: unconditionally cause object files to be placed in the same subdirectory
automake: of the corresponding sources.
automake: You are advised to start using 'subdir-objects' option throughout your
automake: project, to avoid future incompatibilities.
Possible solution:
This may caused by the incompatible between automake and wsim. 
Step 1: Check the version of automake: 
automake --version
If the version is 1.14, then go to step 2. 
Step 2: Downgrade to 1.12
sudo apt-get remove <application_name>
Download automake 1.12 in: http://ftp.gnu.org/gnu/automake/
And install according to readme in automake.

Error 2: If you meet errors as follows during make in the example source code: 
warning: #warning <io.h> is deprecated, please include <msp430.h> [-Wcpp]
...
error: '...' undeclared...
...
Possible solution:
This is caused by the incompatible setup CUP version of virtual machine. 
Go to makefile of the example source code, and change:
CPU        = -mmcu=msp430x1611
to: 
CPU        = -mmcu=msp430f1611

Error 3: If you meet:
error: unknown type name ‘uint8_t’
Possible Solution
Add #include <stdint.h> in the corresponding .h file. (In my case, it is Led.h)